Recent Posts

Pages: 1 2 [3] 4 5 ... 10
Using NASM / Re: How to build NASM / NDISASM?
« Last post by Frank Kotler on February 14, 2019, 10:07:06 PM »
Hi Ruud,

I don't think I can help you with this. I know little of the build process and nothing of OpenWatcom. I just do "./configure" and "make install everything". The developer's list might be able to help you.

I might be able to suggest another alternative. I'm quite fond of Agner Fog's "objconv" as a disassembler. Look around for it...


Announcements / Re: down?
« Last post by sonictk on February 14, 2019, 09:51:10 PM »
Is there a mirror somewhere for the nasm compiler or manual? It's kind of annoying trying to figure stuff out without access to it.

Edit: site is back up. Many thanks to Frank, Cyrill and Hans who responded to my query; going to take this opportunity to download the offline documentation now just in case...
Using NASM / How to build NASM / NDISASM?
« Last post by RuudB on February 14, 2019, 06:03:28 PM »
Quite some time ago I wrote my own disassembler for the 8088. I expanded it to the 80286 but that job isn't finished yet. I now also need one for the 80386. I can do two things: 1) expand my disassembler again or 2) use NDISASM. But NDISASM lacks some nice features my disassembler has. One thing I could do is add these features to NDISAM.
I tried building the original sources using Openwatcom. IIRC when installing Openwatcom it asked if it coud add itself to the PATH. I refused I don't like it if every program adds itself to the path. So before starting "wmake ...." I added the root directory and binnt to the path using a BAT file. But I still get errors: it cannot find various .h files like "assert.h", to be found in ...\openwatcom\h. I added this directory to the path as well, knowing that it most probably would not help, and unfortunately I was right.

The question: what did I forget / what did I wrong / am I missing something?

I hope somebody can help me. Thank you very much in advance!
Announcements / Re: down?
« Last post by debs3759 on February 13, 2019, 06:40:44 PM »
The volunteers who maintain the site are probably busy. Most don't check in every day.
Announcements / Re: down?
« Last post by FG on February 13, 2019, 06:30:39 PM »

the site is down from 2 days now, whats happening ?  :-\

Programming with NASM / Re: I have a problem with a simple 64bit programm
« Last post by fredericopissarra on February 12, 2019, 07:20:00 PM »
Also, this is wrong:

Code: [Select]
  mov  rdi, rsi; argument
  call atoi wrt ..plt

The 2nd argument of main() is a pointer to an array of pointers. The correct reference is:

Code: [Select]
  mov rdi,[rsi+8]
And atoi() isn't a libc function, but a macro for strtol().
Announcements / Re: down?
« Last post by notabot on February 12, 2019, 05:47:48 PM »
Same for me here... this is unfortunately breaking a lot of my deployment scripts :(

This site can’t be reached refused to connect.
Search Google for nasm us
Programming with NASM / Re: A simple calculation goes wrong
« Last post by Frank Kotler on February 09, 2019, 10:00:05 PM »
Okay. That's a surprise to me - I didn't know there were bugs of that sort in that version. We live and learn! Glad you got it working!


Programming with NASM / Re: A simple calculation goes wrong
« Last post by RuudB on February 09, 2019, 02:56:06 PM »
Hallo Frank,

I just upgraded to 2.14.02 and that one works fine. So it was indeed the version.
Thank you!

Kind regards, Ruud Baltissen
Programming with NASM / Re: A simple calculation goes wrong
« Last post by Frank Kotler on February 08, 2019, 04:50:15 PM »
I am simply unable to duplicate this error. I'm using nasm-2.14.03rc2 - just upgraded to the latest version.

It looks to me like what you'd get if your editor were not producing ascii text. That's not only my best guess, it's my only guess... Wish I could help you more!


Pages: 1 2 [3] 4 5 ... 10