Author Topic: Cannot build nasm on Ubuntu  (Read 3919 times)

Offline Agner

  • New Member
  • Posts: 1
Cannot build nasm on Ubuntu
« on: July 04, 2013, 05:08:08 PM »
I want to build the latest version of Nasm in order to get the newest instructions.
./configure goes OK, but make fails with this message:

false -b docbook -d manpage -o nasm.xml nasm.txt
make: *** [nasm.xml] Error 1

I also tried make install. It gives:
cannot stat `./nasm.1': No such file or directory
make: *** [install] Error 1

I have previously succeded using the method described here: http://www.howtogeek.com/howto/ubuntu/install-an-rpm-package-on-ubuntu-linux/
But this time, I can't find any rpm file.

Please help

Offline Cyrill Gorcunov

  • NASM Developer
  • Full Member
  • *****
  • Posts: 176
  • Country: 00
Re: Cannot build nasm on Ubuntu
« Reply #1 on: July 04, 2013, 05:24:01 PM »
This looks like a bug in configure script. Could you please file a bug by http://bugzilla.nasm.us/ .
Still here is a tip -- install asciidoc package.

Offline Cyrill Gorcunov

  • NASM Developer
  • Full Member
  • *****
  • Posts: 176
  • Country: 00
Re: Cannot build nasm on Ubuntu
« Reply #2 on: July 04, 2013, 09:42:31 PM »
I've pushed a small fix into nasm repo, in next nasm release we will warn a user about lack of required packages on configure stage.