Author Topic: unknown spawno error code 3  (Read 13548 times)


  • Guest
unknown spawno error code 3
« on: September 23, 2004, 03:05:16 PM »

Having trouble getting off the ground on this one...and there doesn't seem to be anything on the net except a page in portuguese google translated (text follows):

August 2004: when trying to mount a program appears the error message: Error Unknown SPAWNO code 3
This is well subtle: the way where if it finds nasm cannot have diretorios with 8 characters more than (This is an old limitation of the one Of)

I don't really know what it means, but I've tried altering paths...anyone have an idea?

Thanks in advance

Offline Frank Kotler

  • NASM Developer
  • Hero Member
  • *****
  • Posts: 2659
  • Country: us
Re: unknown spawno error code 3
« Reply #1 on: September 24, 2004, 01:37:18 AM »
My crystal ball tells me you're using NasmIDE.

This error message is *not* from Nasm. Unless I'm mistaken, it's a "Pascal thing". I was under the impression that it was fixed in recent versions(?). In any case, it's from NasmIDE not finding Nasm - either because it hasn't been filled in in NasmIDE's "options", or for some other reason. Your "Portuguese" source suggests a possible reason - long filenames in the path. You should actually be able to use 11 characters - 8.3 (paths can have a "dot" in 'em, too!). Filenames/pathnames longer than 8.3 are "decadent", in my opinion, and filenames/pathnames with spaces in 'em are pure EVIL!!! Winduhs kindly provides you with "Program Files", by default... Spaces in filenames/pathnames will definitely mess Nasm up - "%include" search paths, etc. If you're stuck with spaces, use the ugly, mangled, "short" name - "progra~1" (which is the "true name", in FAT fs, at least), and the problem should be solved.

Another possible problem is that NasmIDE won't run a Windows build of Nasm (usually called nasmw.exe). You'll need to use either "nasm16" (ugh!) or the djgpp, "32-bit dos" build - neither of which will handle long filenames, so you'll want to avoid 'em, or if you're already stuck with 'em, use the short name.

If by any chance you're using the CD with Jeff Duntemann's book, there are some known issues with the software - it copies off to disk with the "read-only" attribute set. Take a look at his page - - for more info on that. I don't know if it applies to what's on the CD, but the examples downloaded from his site contain some errors (IMO) - mostly just cosmetic. Let me know if you want more info on that...

If I've completely mis-diagnosed the problem - it's *not* from NasmIDE - then I don't know what "spawno error code 3" is. Just like it says, it's "unknown" :)



  • Guest
Re: unknown spawno error code 3
« Reply #2 on: September 25, 2004, 03:47:40 AM »
Hi Frank,

Thanks for your v comprehensive response and anticipating my hopelessly incomplete statement of concerns :-D

Yes, I am using NASM-IDE, I do have Jeff Duntemann's book...and the problem is fixed now, so thank you again.

For future reference to anyone else:  I initially  installed under *documents and settings/...* to match XP's default command prompt path.  Needless to say, it didn't work v well.  (I didn't realise changing the command prompt path requires a registry entry these days.)

Any who, all's good...Thanks so much again.  Joanna