Author Topic: Missing %define's from Win api  (Read 2892 times)

Offline Laocoon

  • Jr. Member
  • *
  • Posts: 14
Missing %define's from Win api
« on: November 18, 2014, 05:44:59 PM »
Before I go off writing my own additions to windows.inc, am I just missing definitions somewhere?

Decided get back into assembly, and one of the first winapi's I'm using was VitualAlloc and I did a file contents search, but none of the files seem to define MEM_COMMIT or MEM_RESERVE. Is windows.inc just incomplete or what happened to these? I'm so confused... :D

Offline Rob Neff

  • Forum Moderator
  • Full Member
  • *****
  • Posts: 430
  • Country: us
Re: Missing %define's from Win api
« Reply #1 on: November 19, 2014, 02:33:06 PM »
Hi, Laocoon.
Yes, windows.inc and many other includes are not complete.  Simply put, no one, including myself, has the time or drive to bring them all up to date.  Subsequently, if you find any missing defines or structs, you should add your own additions.  If you send a patch of things that are missing we can get them into the package for future use.

Offline Laocoon

  • Jr. Member
  • *
  • Posts: 14
Re: Missing %define's from Win api
« Reply #2 on: November 22, 2014, 06:35:47 PM »
I see. I thought this was a conversion off of masm's windows.inc file. hah! Well it's an easy enough fix for me as I come across them, I just thought I got a bad package or something. Thank you for clearing this up!

Offline sellero90

  • New Member
  • Posts: 1
Re: Missing %define's from Win api
« Reply #3 on: December 10, 2018, 11:56:17 AM »
The same thing happened to me as it did to Lacoonte when I joined this post. Thank you for clarifying it as well as I said.